SDK/React starter project

Hi all

I have seen that a few of you started playing with the SDK and are building your own services. This is really awesome! I know our SDK is still a bit rough to get started with. So I wanted to make it easier for you all to get started with using the SDK in the browser, as such I built example project.

The example shows a small swap price service similar to the mobile. It only allows USDC -> BTC swaps, and it not meant to be used for anything serious.

I hope you find it useful in your own personal projects building your own Nash-powered services :slight_smile:

GitHub link: https://github.com/nash-io/nash-react-starter

34 Likes

Great stuff @jankjr, thx!

2 Likes

Wow, looks like you created a Uniswap equivalent in just under 10 commits :innocent:

8 Likes

And 4 of them are readme updates :slight_smile:

1 Like

Great !! During my coding, the most difficulties I had, was websocket handling in a React component context (how to avoid multiple connections, reconnections, React state hook update in ws events)
That would be awesome to have a template for that, as well as React Functional Component programming mode.

EDIT : it’s already functional mode ! that’s cool!!

6 Likes

Sorry for the noob question (first node project!)
I am getting the error:

This file contains the result of Yarn building a package (@neon-exchange/api-client-typescript@npm:5.1.1)

Script name: postinstall

Required node version >=8.9 <11.0.0 not satisfied with current version v12.14.1.

do i have to downgrade my Node?

You can have several versions of node installed, then choose which version you wish to use in the current terminal.

Check out this guide to manage your node versions: https://michael-kuehnel.de/node.js/2015/09/08/using-vm-to-switch-node-versions.html

3 Likes

Oh good point.

Please use nvm for when using this. We are for technical reasons stuck on v. 10.6. But this is not permanent.

1 Like

I am glad I learned React over the past year, will have to take a look at this. Well done!

2 Likes

Awesome work!

2 Likes

after yarn install i get a lot of this:
must be built because it never did before or the last one failed

and when i run yarn start, i get this:
Something that got detected as your top-level application (because it doesn’t seem to belong to any package) tried to access a package that is not declared in your dependencies

Required package: http-proxy-middleware (via “http-proxy-middleware”)
Required by: /home/user/code/nash-react-starter/src/

any help?
btw, yarn error messages sux. lol

Hi @CryptoEks

Thanks for reporting this, I probably forgot to add the package.

I’ll get the repo updated.

1 Like