Unable to use the Nash Equilibrium Beta invite link sent to my mail


I received an invite for the Nash Equilibrium Beta in my mail but am unable to access it.

I received the following error message :slight_smile:

The owner of this website (equilibrium.nash.io) has banned your IP address …

I tried via VPN as well but the same result …

Has someone else faced this issue . Can someone suggest a resolution for it ?

Thanks much.

1 Like

Its closed as of now for update and changes.

1 Like

its funny how it just closed and 1 minute later there are already people complaining about not being able to enter. Maybe the “access denied”-screen can be phrased friendlier and clearer :man_shrugging:

1 Like

Will open tomorrow again. They close is to make necessary updates based on feedback

I am not disagreeing with changing the error message, if that is possible, BUT cmon guys…just use the search function. What’s wrong with you?
Just type “error”, “access denied”, “login” or whatever keyword you can imagine. I bet you find something :wink:


When is this due to be resolved? Still waiting to create an account as a beta tester

See the feedback thread: “We are closing the beta at least until this time tomorrow for deploying new changes. We will be analyzing the beta data so this may expire a bit one day.” It was posted 16h ago

1 Like

Thank you!

1 Like