Transfers getting stuck issue. How is progress, nash?

same problem, can’t withdraw btc to external account. opend a support ticket yesterday.

Let us know of their reply :slight_smile:

Have you checked in the explorer? Personal to external is a simple wallet transfer. You can just drop your personal wallet address in a explorer and see if the transaction was sent.


Sure, I check with, no sign of any transaction.

In the browser I get the error “Your current balance is insufficient for this transfer or you currently have a transfer in progress. Please wait and try again.”

in mobile app it just says “failed to sent funds”

I already tried the guides by the guys from your support and also provided them the requested screenshots they asked for.


Same problem. Try to send btc from nash, clearly enough funds. Make it to the confirmation and suddenly it says insufficient funds or transaction in progress. Nothing shows on explorer or transaction history. Submitted a ticket, pretty unhappy.

@actionkb and @stevezissou both of your cases should have been fixed, if you could please try again.

That worked, thanks for quick reply!

it works now! thanks!

How is the revamped transfer system going?
Could we have a litle development status please?

Thanks in advance!

1 Like

With Q2 ending soon, i’d also really appriciate a update. It’s a primary pain point.