"Network error" on verification app

Anyone else been having this? For the last two days I’ve gotten nothing but a “Network error” whenever trying to verify - “There was a connection problem. Please try again later.” I contacted support 36 hours ago and have heard nothing.

Our support team will get back to you, but I’ve made an inquiry too since it seems odd that this error should persist so much.

Can you say where are you trying to use the app from? What kind of connection are you using? Are you on a VPN?

Thanks Chris, I’m in the Czech Republic, I did have a vpn on initially but turned it off at the start of the problem.

Did you declare your residence as being in the Czech Republic?

Have you tried using your phone by connecting to a wifi router, rather than using mobile internet?

I got the same error with the app on OS though I was connected to a wifi router.
Now my verification status is on ‘pending’, so I think documents has been sent.

I figured it out - I had completely forgotten I had a VPN on my phone as well. Turned it off and verification worked like a charm. Thanks Nash, well done!