Nash Store Experience Feedback

Hello :wave:

  1. When it redirects me to my app (to pay for my order) it shows that the address is invalid: (even if the address is correct)

2.When I tried to copy the address, ( pushing the copy button) it didn’t give me the option to Paste it in the app:

  1. When I copied the entire address, without the quick copy button, it worked ( I was able to Paste it in the app)

  2. Would be great to have the option to pay with BTC that is in my trading contract. ( the transfer from trading to personal is one more step that and, an expensive one.

  3. Paying with USDC is easier then BTC ( my brain feels guilty when I am paying with BTC)

Hopefully this helps :handshake:


@Radu could you report which version of the app you have? You can find it in the settings.

1 Like

I couldn’t find anything else:

This one? :upside_down_face::thinking:
Just updated it to 2.234, didn’t know there is an update :smiley:
Will check if it has the same problem, will let you know if any of this persists.
Sorry :neutral_face:

I have just checked:
nr: 1 is fixed
Nr: 2 is the same ( tried to paste is somewhere else ( not in the app ) and it doesn’t work. ( but is not important for me, the app opens up with the right address)


Thanks, good to know - we will fix (2) regardless.