> Failed withdrawal of 7K USDC

Yesterday I decided to start using the exchange for larger trades. After my first trade I wanted to transfer USDC from the trading contract to my personal wallet and it’s stuck for more than 12h. Contacted support. Very responsive but they told me they are working on it and they would send me an update before logging out… but no news and it’s weekend. Not happy with this at all! I’m missing opportunities.



yes i can feel how irritating it is. Please team do something about it.

1 Like

Although I don’t think such a technical issue should be allowed to happen, technical issues can always arise. What I do expect is that there is direct communication. It’s not about a million dollars, but it’s not about 100 either.


it is not acceptable it is true. I hope you have a solution @canesin


I hope I will hear something soon and that a solution is found.

1 Like

GMS looking at your address on the blockchain I can see there is two reverted transactions with “out of funds”. You can see this by putting the address in etherscan.io

Could you please check this link: https://app.nash.io/funds/support/retry-transactions to see if you can retry those?

1 Like

Hi Fabio,

Support already ask me to try that yesterday. I tried 2 times but it didn’t work.
I’m not sure if you are in direct contact with the settlement team or support team regarding this problem but they told me they are trying to solve this issue asap… Of course I hope that this will be sorted out as soon as possible and that I can access my funds.

1 Like

@canesin I want to try again but each time the reverted transaction cost me about $4 I think so I don’t know if its useful to try again.

No updates. No solution. This is bad. It’s been more than 2 days that I can’t access my money. This is very bad.

1 Like

Dear @GMS, you will have to use the link I sent above. What I am providing you is the solution above. Let me explain this is bigger detail:

  • If a transaction has failed in the Ethereum blockchain - it will never settle. Meaning you can wait as long as you want but it will not “go through”.

  • We can’t send a transaction in your behalf, so you need to retry sending the transaction.

This means that - the moment I could see in the explorer (and commented above) that there was a failed transaction in your address, you could already retry it - one might ask why it failed? I looked and there was a long pending transaction on your address still waiting to go though. This TX was spending funds released on that TX.

We know this experience is problematic but is basically how Ethereum works. There is work in progress on some big redesign for the transfer sections and will be deploying new Ethereum smart contracts all to make the UX of congested Ethereum easier for users where we show this statuses right on transfers and let people retry from there.


I wonder:

  1. is the USDC still on your wallet as a balance if you check on your https://etherscan.io/ ?
    In that case money is not stuck and still available to you.
  2. There any pending transactions that are still waiting (not failed) ?

9 days ago, my second withdrawal from trading contract to personal wallet failed again! This is really an issue. First I didn’t have enough ETH to make the transaction (my mistake). But after funding the personal wallet, support provided me with a link to retry the transfer again but there was no transaction to retry.

Now it’s been a few days I’m still waiting for a solution…

Last time, when my 7.5K USDC transfer failed, support told me it took a full balance sync on the state channel. It took 80 minutes to complete, which is longer than usual, but still within range of normal blockchain fluctuations they informed me. I can only guess this is the same problem, but why does it take so long?

Two things are unfortunate. This is the second time I’ve bought USDC through NashCash and I run into issues (and miss opportunities) twice. And I recently had a family member (who is a full rookie) buy a fairly large amount of USDC through NashCash and they have the exact same problem.

Another problem is that because of this (unfortunately) I no longer dare to use Nash as a fiat onramp. Neither does my friend. I also assume that there are others that have the same experience which ain’t good.

Sorry to hear about these issues. This is upsetting to read.

Yes, I am quite upset. The reason I’m posting it here is because I want to share my experience and I want to get @canesin’s attention (if he has the time) because I find this important.

As a fairly large investor in Nash I want Nash to succeed. Apart from the fact that I can’t access my own money this is a stressful situation. This shouldn’t happen and it sucks because I’m trying to onboard people with capital and they have their funds “frozen” the first time they use the platform.

I also have to say Nash support is very friendly and helpful and I assume they are trying to come up with a solution asap although I think when it comes to quite substantial amounts of money should keep me even better informed.


Update: team is working on the settlement system. It’s taking longer since its a back end issue associated with the ETH settlement system. It’s not a user specific issue.

I just got a message from the person who I tried to onboard. He received his funds from the trading contract. I hope mine will be released soon as well.


Update: “Our transfers for ETH are still going through but its a few transfers that have issues and requires intervention from the engineering team”. :unamused:

No news, no solution. Wow!
This is unbelievable.