Can not see any tokens in nash extension other than neo/gas

I can not see any tokens in nash extension other than neo/gas, after adding them from “Tokens List” all showing 0, i tried changing primary node as advised by the extension but still showing 0, i tried to remove the extention and add install it again, still same ! anybody facing same issue??

I haven’t used the extension for almost a year now so have no idea. Nash support should be able to help though:

Did you check your public address on the neoscan site to see if your funds are still on that neo address?

yes, i have several tokens in the wallet not only nex and all balances are shown on neo explorer but on nash extension all balances are 0 except neo & gas !

Ait so if you need access to your funds you could easily use neonwallet and import your keys their. But still strange you can not see it in your Nex extension indeed. better put in a ticket to Nash support. keep us posted with the results thx

You need to use Neoscan.io (Neotracker has been glitching)

the balances are shown in the explorers neoscan & neotracker, the problem they are all 0 in the extension !

Are you on a Mainnet?
image

and try different nodes too

btw I can’t see SPOT coins too

of course i am on mainnet, i see the neo & gas balances and even their dollar value normally, but all other tokens balances are 0, i changed the nodes several times and removed/reinstalled the extension but still same.
it seems i am the only one with this issue which is really wierd !

read my post again, I can’t see them too

Ah ok, it was not clear since you were asking if i am on mainnet, anyway at least its not only me