Can't withdraw ETH for 30 minutes

Can’t withdraw ETH from trading to personal account. Other coins are working.

Your balance is currently syncing. I have just checked my wallet/transfer, but do not have this issue. It also states that is should only take about 5 minutes. If it is already taking 30 minutes and you worry, you should contact support.

I have contacted support. Got no answer. 40 minutes already…

it appeares AFTER I click Send button.

Just tried it and it worked. Don’t worry, they will reply. Some support desks will take days before they answer. 30 minutes is nothing.

I mean I can’t withdraw it for 50 minutes already. Why are you able to do it?

Don’t know. Took about 10 to 15 seconds.

I can neither deposit nor withdraw ETH from Personal to Trading and from Trading to Personal accounts. fml

If people have issues I recommend contact support instead of posting personal related issues over and over again!

2 Likes

You made a post because you didn’t get an answer in 40 minutes, come on man :sweat_smile:. Anyway, I am not surprised by that attitude. We now live in a world of instant gratification.
I suggest you be a bit more realistic and understanding with your expectations in these early days of the MVP. Things should gradually pick up in the coming weeks and months.

1 Like

The problem is not with the support. It’s rather basic function and it’s not working.

I see. Still give it some time. As you say, it is a basic function and would definitely be fixed soonest.

1 Like

Only issue I’m seeing here are the absurdly high fees. 30x the recommended @canesin
Please adjust the fee or allow for users to set their own custom fee.

1 Like

I still can’t withdraw ETH and USDC even with $2 fee. And support is not responding anymore…

was this ever solved?

Eventually, yes (7 hours later). But without an assistance from support (no response after 2 messages). Suggested solution had nothing to do with the issue. Now it’s really scary to use the platform because you can’t be sure if you manage to withdraw your coins in time. Which is critical in many cases.

wait… if the suggested solution had nothing to do with the issue, how is it solved now?

Well, it’s “solved” just because I managed to do it. But it was something else not these:
"Thank you, it seems your browser doesn’t correctly update the info it gets from the server.

Could you please perform the following steps?

  1. Close your browser
  2. Sync the internet time on your computer (this is most likely the issue)
  3. Clear all cache and cookies from your browser for ALL TIME
  4. Go to Internet Options > Connections > “LAN settings” and untick all three boxes in this screen
  5. Perform a hard reset on the Nash exchange page (ctrl + F5)
  6. Try to make a new transaction

Please let me know if this worked for you. "

Nobody answered my emails after this.

I try to understand your communication with the support.
So you followed the steps and it did work or not?

I followed the steps and it did NOT work. I told the support that it didn’t work. I did it 3 times. Nobody responded. Then 7 hours later I tried again and it just worked. Maybe it was ETH network congestion. But I want to hear it from the support.

1 Like